返回列表 上一主題 發帖

[發問] amfphp在linux下安裝失敗,弄好久了(參考Flash 資料庫應用即戰力這本書)

本帖最後由 amxxxxma 於 2010-9-12 00:30 編輯

回復 10# 小誌



抱歉ˊˋ我內容沒有打好,我有按照書本上面走,
我打上的 開啟browser... 就是/amfphp/browser/裡面內建那個瀏覽器,
我是用Firefox開啟的,網址就是錯誤訊息裡面的 details = "http://192.168.17.43/~jingyu/amfphp/gateway.php"

我有在xp上嘗試安裝,都OK沒問題,
但是在Linux上就一直失敗,一直無法安裝amfphp進入除錯器,
而且我的apache也都有啟動,也可以執行html,php也可以連結資料庫取得資料,
防火牆也確實關閉,SELinux都關掉了,

會不會是在apache要設定什麼?
amfphp裡面程式碼需要做更改?
還是Linux的服務要關閉什麼還是開啟什麼之類的?
那個錯誤訊息我的認為是,好像是什麼擋住了,不能通過,是安全性的問題嗎?

謝謝小誌幫忙,我再繼續加油看能不能找出問題好了∼謝拉@@

TOP

amfphp 1.9 不能用php5.3版本,只能用以下的版本。否則在gateway.php就會有Error!
所以請先檢查你的PHP版本。
(AppServ 2.6.0,php版本是5.3或以上,所以在WIN系統同樣不能用)
心安,平安   為了論壇的永續經營,您不妨 贊 助 論 壇
發表任何無意義的感謝或灌水文章一律砍,珍惜帳號,請詳閱版規!!

TOP

本帖最後由 amxxxxma 於 2010-9-14 17:22 編輯
amfphp 1.9 不能用php5.3版本,只能用以下的版本。否則在gateway.php就會有Error!
所以請先檢查你的PHP版 ...
小誌 發表於 2010-9-14 12:45



amfphp 1.9 不能用php5.3版本,只能用以下的版本。否則在gateway.php就會有Error!
所以請先檢查你的PHP版本。
(AppServ 2.6.0,php版本是5.3或以上,所以在WIN系統同樣不能用)

這個問題之前我之前有找到過,原本要試試看的,但是因為對linux不熟,手動安裝弄好久於是放棄,
我是用yum安裝(線上安裝最新的,所以PHP是5.3.3版本),想說會有解決方案,找了好久還是沒有,
看來是要是安裝5.3以下的,真是自討苦吃ˊˋ

我在找看看手動安裝的方法,另外想請問yum安裝可以選擇版本嗎?還是有可以選擇版本的安裝方法(自動安裝的)?
因為手動安裝不太知道安裝在哪(是把php裝在etc資料夾裡面嗎?對指令有點不太清楚)
謝謝小誌︿︿

TOP

        靜思自在 : 一個人不怕錯,就怕不改過,改過並不難。
返回列表 上一主題